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Introduction to MultiView 2008 Server Edition
MultiView 2008 Server Edition, referred to as MultiView 2008 SE, is composed of:

• MultiView Terminal Emulator

• FutureSoft License Manager

MultiView 2008 Server Edition is a complete solution for thin clients to access UNIX with 
MultiView Terminal Emulator.

MultiView Terminal Emulator

MultiView Terminal Emulator is a comprehensive PC-to-UNIX connectivity package that 
can be installed on desktops with one of the following:

• Windows 2000 Terminal Services

• Windows 2003 Terminal Services

• Windows 2008 Terminal Services

• Citrix 

It consists of terminal emulation, file transfer, local and remote printing and a MultiPing con-
nectivity testing tool. UNIX applications are revitalized in less than an hour with the built-in 
face-lifting tools. Face-lifting enhances the user interface of UNIX applications, providing 
features such as mouse navigation and Windows-style buttons.

FutureSoft License Manager

The FutureSoft License Manager monitors and controls licensing for MultiView. It is installed 
on a Windows server.

Minimum Requirements

One of the following is required for installation of MultiView 2008 Server Edition:

• Windows 2000 Server

• Windows 2003 Server

• Windows 2008 Server
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Contacting FutureSoft Support

Before contacting Technical Support, please collect all information regarding your question. 
This should include hardware and software configurations for all systems with MultiView 
License Manager, the MultiView version number, any other software running when you expe-
rienced the problem, and the exact sequence of steps that preceded the problem.

For prompt and effective service, be sure to provide the following information when contact-
ing us:

Your name
Company name
Company address
Company phone/FAX numbers

Contact us at:

• Ground: Futuresoft, Inc.
Technical Support Services
12012 Wickchester Lane Suite 600
Houston, TX 77079-1222

• E-mail: support@futuresoft.com

• Phone: Monday through Friday
8:00 am to 5:00 am pm (CST)
281.496.9400
1.800.261.6357

• Fax: 1.281.496.1090

• Web site: http://www.futuresoft.com
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Installing MultiView 2008 Server Edition
MultiView 2008 Server Edition (MultiView 2008 SE) is comprised of:

• MultiView 2007 Desktop

• FutureSoft License Manager

MultiView 2008 Server Edition is a complete solution for thin clients to access UNIX with 
MultiView Terminal Emulator.

Installing FutureSoft License Manager

You must install FutureSoft License Manager before installing MultiView 2008 SE. Where 
you choose to install FutureSoft License Manager components depends on the complexity of 
your enterprise. It is necessary to consider the following:

• Although you may have installed one of the concurrently licensed MultiView 
products several times, you install MultiView License Manager only on one server. 

• License Manager must be installed on a system listed in the Minimum Require-
ments section in this chapter.

• The License Server can be the same system as your Windows Terminal Server if 
required, but this is not necessary.

All components can be installed on one server. In a larger enterprise with more than one 
server, one system is designated as the License Server and has the License Server service 
installed.

Note
Only one administrator can configure a License Server at a time.
6
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Installation Steps

1 On the MultiView CD, navigate to and select the License Manager folder.

2 In the License Manager folder, double click FutureSoft License Manager.msi.

3 In the Welcome dialog, click Next.

4 In the Customer Information dialog,

a In User Name, enter a complete name.

b In Organization, enter a company name.

c Click Next.

5 In the Destination Folder dialog:

• To accept the listed default install-folder location, click Next.

• To change the install-folder location:

(1) Click Change.

(2) In the Change Current Destination Folder dialog, use standard navigation 
techniques to create a new folder or navigate to a different folder.

(3) Click OK.

(4) Click Next.

6 In the Ready to Install the Program dialog, click Install.

7 In the InstallShield Wizard Completed dialog, click Finish.
7
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Post Installation Issues

Hide the terminal emulator window title

In the Windows Terminal Server environment you can start the MultiView Terminal Emula-
tor on connection. By default, the terminal emulator opens maximized in the Client window. 
This can be confusing, as two window titles are shown. You can suppress the terminal emula-
tor window title from the View menu. This option is saved in the .zzt file.
8
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Working with FutureSoft License Manager
FutureSoft License Manager allows you to keep track of license use which is extremely useful 
for billing purposes, etc. It does this by making a log entry whenever it releases a license. 
Stored details include:

• Product name
• Connect date
• Connect time
• Length of time connected
• IP address of the Client host computer
• Username for the computer
• Disconnect date
• Disconnect time

This means that you can obtain detailed information on who has used one of your licenses, 
when they used it and for how long. FutureSoft License Manager also gives you the facility to 
import this log file into your favorite reporting tool such as Excel or Crystal Reports to view 
it. The log file is called LMCClientConnect.csv and is created in a subdirectory of the Future-
Soft License Manager installation directory called “log”.

To open FutureSoft License Manager

1 On the Windows Start menu, highlight FutureSoft, Inc.

2 In the FutureSoft, Inc program group, highlight Futuresoft License Manager and 
then select License Manager.

The FutureSoft License Manager dialog appears.
10
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All stored licenses appear in the Licenses window. All licenses currently being used are listed 
in the Licenses In Use window.

To add a license

1 In the FutureSoft License Manager dialog, click Add.

2 In the Add License dialog, enter one license number and click OK.

The added license appears in the Licenses window. The Total licenses count reflects 
the updated licenses total.

To remove a license

• In the FutureSoft License Manager dialog, select a license and click Delete.

The license is removed from the Licenses window. Total licenses count reflects the 
updated licenses total.

To update the display of licenses in use

• Click Refresh.
11
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To set up MultiView 2007 to retrieve licensing information from a MultiView 2008 license 

manager server

1 In the MultiView 2007 program group, select Licenser.

2 In the MultiView Licenser dialog, enter the MultiView SE license number and click 
License.

The license is verified with the following message.
3 Click OK.

The MultiView SE Server dialog appears.
4 In the MultiView SE Server dialog, enter the host name or IP address that has Multi-
View 2008 License Manager installed.

5 Click OK.
12
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License Manager Log File
As listed previously the License Manager log file displays nine fields of information for each 
connect/disconnect to the License Manager service. 

To view the log file

• Click Show Log.
Figure 3.2
License Manager Log window
Change the display by:

• Selecting a new font  (Format > Font)

• Turning Word Wrap on or off   (Format > Word Wrap)

• Displaying or hiding the Status Bar   (View >Status Bar)

Change and navigate through the data by:

• Going to a specific line   (Edit > Goto)

• Changing data   (Edit > Replace)

• Find a character string   (Edit > Find)   (Find > Find Next)

Print the data by:

• Setting page properties   (File > Page Setup)

• Printing   (File > Print)

CAUTION!  The log file does not have an auto-purge mechanism.

To reduce log file size:

1 Stop License Manager services.
2 Open the file in Notepad.
3 Highlight data to remove.
4 Press Delete.
13
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Configuration Files
When you have successfully installed your MultiView products, there are a number of options 
that can be configured to allow you to control how the applications are used. One of the key 
advantages to performing one of the central installations is that the product can then be 
administered from a central point. This means that you can configure one copy of MultiView 
Terminal Emulator and share it with any number of PCs.

You can also control the features made available to users and which configuration options 
they can manage, using Windows Policies. After configuring product features, the configura-
tion information can be saved as a file. A hierarchical structure is used for configuration files 
where each component application has its own configuration file:

• File Transfer .zzf

• Terminal Emulation .zzt

• Wizard Defaults .zzd

The terminal emulator configuration file (.zzt) contains a number of components that can be 
embedded into it, or saved as separate files:

• Connection Details .zzc

• Configurable Popup Menu .zzp

• Configurable Toolbar .zzb

• Emulation Details .zze

• Keyboard Mapping .zzk

• Rules Agent Editor .zzr

• Script .zzs

• Uninstall File .zzu
14
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The status (embedded or not) of these configuration files can be managed from within the 
terminal emulator from the Component Configuration Files dialog, accessed from the File 
menu with the Components selection.
Figure 3.2
Component Configuration Files dialog
• To save or embed one of the six component configuration files, simply select it 
from the list and choose either Save, Save As or Embed.

• To open a component without embedding it into the .zzt file, click Open instead. 
This preserves the original component file.
15
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Sharing Configuration Files

If you have MultiView Terminal Emulator installed on a number of PCs, it may be advanta-
geous to share a set of configuration files, either between one group of users or between 
everyone in your entire organization. This means that for each type of configuration you only 
have to configure one copy. When creating a configuration file that you wish to share, make 
sure that all relevant components are embedded (in the case of a .zzt file) so that you only 
have one file to share, or two files if you include a login script.

The easiest way to share configuration files (.zzt or .zzf) is to place them in a central location 
and then create shortcuts on user desktops to these files. When, for example,. a user double-
clicks on a .zzt shortcut, the terminal emulator will start with the central configuration you 
have created. Useful options that can be configured include:

• User name options

• Initial window size (when an application first opens)

• Hide Titlebar (available on the terminal emulator to hide the window title when 
the window is maximized)

With MultiView 2008 SE, configuration settings are received from the Server as the terminal 
emulator opens. This means that the file is shared from a central location. However, because 
these settings are only read as the files opened, any subsequent alterations will not take effect 
until the client has disconnected and connected again.
16
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Wizard Defaults
The Terminal Session Wizard allows you to quickly and easily create login scripts, make the 
terminal emulator open a connection, and send commands to a remote system. It guides you 
through establishing a connection and configuring a terminal emulator using the default set-
tings specified during installation.

The Terminal Session Wizard can be used with MultiView Terminal Emulator and can be run 
after installation, each time the terminal emulator is started or from the Start menu. Each of 
the parameters that can be set in the Wizard have a default value. This value is determined by 
the Wizard Default file (.zzd). This file can be set up so that the Wizard only asks for certain 
parameters, such as username and password.

Editing a Wizard Defaults (.zzd) File

The .zzd file is in plain text format and can be edited in Notepad. The file is found in the 
MultiView program folder. Double-click the file to open it in Notepad. By default, each step 
is commented out with a semicolon (;) and terminated with the expression ‘/skip’ as shown in 
this short extract:

; Set transport to use
;Transport=modem /skip

; Name of host to use
;Host=unixhost /skip

; Name of emulator to use
;Emulator=VT320 /skip

Remove the semicolons to provide a default value. The /skip expression causes the Wizard 
skip the step and apply the specified default value. Removing this expression causes the Wiz-
ard to prompt the user for a value. If the user clicks Next, the default value specified in the file 
is used.

Terminal emulator configuration information is stored in a .zzt file. Some of the information 
can be stored in other files. The .zzt file is configured to point to these external files which 
can be shared between a number of machines. The .zzt file stores the following:

• Remote application help sequence
• Terminal emulator closure sequence
• Information exchange details
• Font
• Keyboard mapping details
• Connection details
• Start up options
• .zzs file name containing scripting details
17
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Information that can be saved externally is saved in the following component files:

.zzc configuration

Used by file transfer and the terminal emulator to save the connection details of 
remote systems.

Details saved

• Remote system name

• Username

• Protocol details

• Password request

.zze configuration file

Used by terminal emulators to save emulator properties.

Details saved

• Attribute mapping

• Number of lines in display and scroll back buffer

• Cursor style

.zzk configuration file

Used to save keyboard mappings independently of a terminal emulator. This type of 
configuration file can be loaded and used by a terminal emulator.

Details saved

• Key mappings

• Keys assigned to escape sequences

• Keys assigned to .zzk script files

• Keys assigned to launching applications

.zzr configuration file

Used by a terminal emulator to save details on configured rules for the application 
currently in use.

Details saved

• Details on all rules that have been configured
18
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.zzs configuration file

Used by terminal emulators to save details on scripting. This type of configuration file 
can be loaded and used by a terminal emulator.

Details saved

• Connection and login information and commands to launch remote applica-
tions

.zzp configuration file

Used to save the popup menu item preferences.

Details saved

• List of configured pop-up items

.zzb configuration file

Used to save the configurable toolbar preferences.

.zzf configuration file

Used by file transfer to save settings to be used when connected to a remote system.

Details saved

• General name
• Initial directory
• Anonymous login options
• Auto connect
• Listing type
• Log details
• Listing type details
• Transfer options
• Refresh options

.zzd configuration file

Used by the Terminal Session Wizard.

Details saved

• Default values for the Wizard responses
19
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To save configuration information into a component file

1 On the File menu, select Components.

The Component Configuration Files dialog (Figure 2.1) appears with a list of compo-
nents that can be loaded or saved separately from the .zzt file. 

2 Highlight a component and click Open or Save.

Note
When loading new components, you will save a new .zzt file by choosing Save on the File menu. Close the ter-
minal emulator, then re-run it and open your .zzt file to see the changes with the external components you have 
added.

The Embed option allows you to incorporate component configuration files back into the 
.zzt file.
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