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Chapter 1
Introduction

Thank you for choosing the DynaComm Connectivity
Series 9—the most powerful terminal emulation product
available for Windows. FutureSoft maintains an excel-

lent source of easily accessible information on the World
Wide Web. Find answers to your questions, check out new
product information, view demonstrations of FutureSoft
products, and more at www.futuresoft.com

This manual:

* Introduces you to the features and capabilities of the

DynaComm Connectivity Series in chapter 1.

*  Guides you through installation of a single user copy
of the software in chapter 2.

*  Demonstrates how to use the basic functions through

a tutorial in chapter 3.

*  Reviews all removal procedures in chapter 4.
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DCS 9 Features

Standard features in DCS 9 include:

¢ Full suite of standard emulations

Base product emulations include:

ADDS VP/60

AT&T 605/705

ANSI-BBS (with SCO ANSI extensions)
Digital VT Series (52/100/102/220/320/420)
TeleVideo 925/950

Wyse 50/60

Additional add-on emulations:

TN3270  HP 700/94 AT&T 4425
TN5250  Tandem 6530

* A range of standard connectivity options
Base product connectors include:

Direct Serial

Meridian LAT32

Modem (TAPI)

Telnet (TCP/IP and IPX/SPX)
SSH 1

SSH 2

Additional connectors:

Microsoft SNA Server (with TN3270 Client
Option)

Transport Layer Security (TLS) (with TN3270
Client Option)

*  Full suite of standard file transfer protocols

Base product file transfer protocols include:

Kermit FTP
XYModem ZModem

Additional file transfer protocols:

INDSFILE (with TN3270 Client Option)
IXF (with Tandem 6530 Client Option)

e Drag-and-drop file handling

Load a session, memo, or script by dragging corre-
sponding icon into the DCS application window.

Euro symbol support

Input or display the euro character representing Euro-
pean Union common currency.

Menu Editor

Use the menu editor to customize application-level
menus to send a string, launch an application or

script.
OLE-compliant text editor

An OLE-compliant text editor is included in the base
product. Embed documents from other applications

into a memo document.
Powerful event-driven scripting language

An integrated, full-featured script language with over
350 commands and functions that include condition-
al execution, subroutine execution, event handling,
and the creation of custom menus and dialog boxes.

Toolbar editor

Customize application toolbar to create custom
toolbar buttons to send a string, launch an application

or script, or perform a menu command.
Y2K Compliant

DCS 9 contains no date calculation functions. The
only use of dates is through scripting functions that
make a call to the Windows operating system and use
the date provided by this system. Windows dates are
based on a four-character year and, therefore, are not
affected by the change of the century.

WinHLLAPI and EHLLAPI support (TN3270 and
TN5250 Client Options only)

DCS 9 includes both 32-bit EHLLAPI and 32-bit
WinHLLAPI dynamic link libraries to support
Microsoft Windows' applications requiring HLLAPI
interfaces. Custom applications can call these libraries
directly to interact with TN3270 and TN5250 ses-

sions.
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Client Option Packages AT&T 4425 Client Option
To expand the functionality of DCS 9 to meet specific ¥ Supported Emulations
enterprise requirements, Client Option packages for specific o AT&T 4425

host environments are available. These are add-on emula-
tion products that require installation of the base product *  Equivalent AT&T 6539 functionality
before installation of the individual client option. Purchas- ¥ Network Connectivity

ing an individual emulator allows for supporting a unique

The AT&T 4425 Client Option supports the follow-

computing environment and eliminates the expense of ) ) }
ing connectors included in the base product:

unnecessary emulations.

Each Client Option presents the same graphical interface * Direct Serial

as the base product to provide for a consistent computing *  Modem (TAPI)
environment. It also supports multiple emulation sessions e Telnet (TCP/IP and IPX/SPX)

from within a single instance of the application just as the
base product allows. ¥ File Transfer Protocols

The AT&T 4425 Client Option supports the fol-

lowing file transfer protocols included in the base

product:

e FTP

*  Kermit

*  XModem
*  YModem

e  ZModem
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HP 700/94 Client Option

¥ Supported Emulations

HP 700/92
HP 700/94

¥ Product Highlights

Hotspot support

Support for downloadable characters and soft
fonts

On screen function keys

¥ Network Connectivity

The HP 700/94 Client Option supports the follow-

ing connectors included in the base product:

Direct Serial
Modem (TAPI)
Telnet (TCP/IP and IPX/SPX)

¥ File Transfer Protocols

The HP 700/94 Client Option supports the following

file transfer protocols included in the base product:

FTP
Kermit
XModem
YModem
ZModem

Tandem 6530 Client Option
¥ Supported Emulation
*  Tandem 6530
¥ Product Highlights
e EM3270 support
*  Block mode type ahead
*  Hotspot support
¥ Network Connectivity

The Tandem 6530 Client Option supports the fol-

lowing connectors included in the base product:
*  Direct Serial
¢ Modem (TAPI)
e Telnet (TCP/IP and IPX/SPX)
¥ File Transfer Protocols

The Tandem 6530 Client Option supports the fol-

lowing file transfer protocols:

e IXF
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TN3270 Client Option TN5250 Client Option

¥ Supported Emulations ¥ Supported Emulations

e 3278 Models 2 -5

e 3279 Models 2 — 5 (with and without extended
attributes)

e 3287 Telnet printing support
e TN3270E with print
Product Highlights

e EHLLAPI
(32 bit dynamic link libraries to support
Microsoft)

e WinHLLAPI
(Windows applications requiring HLLAPI

interfaces)
*  Hotspot support
e LU1/LU3 print
Network Connectivity

The TN3270 Client Option supports the following

connectors:
*  Microsoft SNA Server with print support
e Telnet

e Transport Layer Security (TLS)

File Transfer Protocols

The TN3270 Client Option supports the following

file transfer protocols:

e INDS$FILE (supports TSO, CICS and CMS)

* 5250 Models 2 — 5
* 3812 Telnet printing
e TNS5250E with print

¥ Product Highlights

e EHLLAPI
(32 bit dynamic link libraries to support
Microsoft)

e WinHLLAPI
(Windows applications requiring HLLAPI
interfaces)

*  Hotspot support

¥ Network Connectivity

The TN5250 Client Option supports the following

connectors:

e Telnet

¥ File Transfer Protocols

The TN5250 Client Option supports the following

file transfer protocols:

e FTP
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New In DCS 9

¥ New file version numbers

In this release DCS 9 and all add-on Client Option
files have a product version of 9.2.0.0.

Transport Layer Security (TLS) connectivity support

for TN3270 Client Option

TLS option is now available on the Session sub-tab in

the Session Properties dialog. Corresponding strings/
keywords are provided in the EMULCONTFIG and
CONNCONFIG scripting commands.

¥ Documentation Library Update

The DCS 9 documentation library consists of:

Getting Started with DCS 9 for Users
(eBook)

Designed for the user; includes features overview,
installation and configuration procedures and a
tutorial covering the major DCS 9 functions.

Getting Started with DCS 9 for Administrators
(eBook)

Designed for the System Administrator; focuses
on the use of Web Install and DynaComm Multi-
user Administrator functions.

Script Language Reference*
(eBook)

Technical information for all commands and
functions used in the DCS Scripting Language.

Release Notes* (readme.doc)

Includes last minute information not included in
the documentation as well as important items of
particular significance.

DCS 9 Online Reference*
(Help system)

Technical information for DCS 9 features and
functions and all Client Options.

e FSFTP Online Reference*
(Help system)

Technical information for the FutureSoft 32-bit
File Transfer Protocol utility.

* HLLAPI Auto-Launch Configuration Online Refer-
ence* (Help system)

Technical information for using HLLAPT calls
with third-party applications.

e Visual Basic Client Online Reference*
(Help system)

Technical information for Visual Basic Interface
functions.

e Script Language Online Reference*
(Help system)

Technical information for all commands and
functions used in the DCS Scripting Language.

e DCS 9 Administrator Online Reference*
(Help system)

Technical information for installation and
maintenance of DCS 9; includes DynaComm
Multi-user Administrator information.

* These items are provided on the installation CD-
ROM in the /documentation folder. The most current
versions of electronic documentation can be down-
loaded from http://www.futuresoft.com/support.
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Upgrading to DCS 9

All DCS 7.1.0.4 (and earlier) installations must be removed
before installing DCS 9. Do not install DCS 9 over an older
installation of the DynaComm Connectivity Series.

Do not mix install types. For example, if DCS 9 is installed
with the Standard Install method, do not use Web Install to
install Client Options - use the Standard Install method to
install Client Options.

Getting Help

When you need help with DCS 9, use one of the following:

¥ Release Notes (readme.doc)

Review the readme.doc file before using DCS 9. This

document provides last-minute information.

To open the readme.doc file

1 On the Start menu, select Programs and then
click DynaComm Connectivity Series 9.

2 On the DCS 9 menu, click Read Me.

¥ Electronic Help

Online References

The Online References contain the most current
and complete information about DCS 9 func-
tions and utilities.

To use an Online Reference

1 On the Help menu, select Contents to
display the Master Help Explorer window.

2 In the Explorer pane of the Help window,
select an online reference to view in the

Contents pane.
To use Context-Sensitive Help

* With a dialog or screen on display, press
the F1 key or click the Help button in the
dialog.

To use Script Help

1 Open a script file with the DCS 9 Script
Editor.

2 Enter the full name of a command or func-
tion.

Do not select any keywords or other
parameters.

3 Highlight the command or function and
press F1.
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e eBooks

eBooks are in Adobe Acrobat PDF format and
require the Acrobat Reader for display. To down-
load the Acrobat Reader, visit www.adobe.com.

— To open, double-click the PDF file name.
¥ Help on Help

If you're not familiar with the Windows online Help
system and functions, select Help from the Help
menu. This opens the Windows Help file that de-
scribes how to use a standard Windows Help system.

Documentation Questions or Comments

If you have any questions or comments about DCS
9 documentation, we would like to hear from you.
Please contact us via e-mail at docs @futuresoft.com.

Product Support

If you don’t find the answer in the documentation to
your question or problem, registered users of DCS may
call FutureSoft Technical Support for assistance. Standard
telephone support is available weekdays, 8 a.m. to 5 p.m.,
Central Standard Time (CST).

Before contacting Technical Support, gather details about
your question which should include all hardware and
software configurations, the DynaComm version number
(found through the About DynaComm option on the Help
menu), any other software loaded (including TSRs) when
you experienced the problem, and the exact sequence of

steps that preceded the problem.

Phone Number:
Fax Number:

1.281.588.6868 (USA)
1.281.496.1090 (USA)

E-mail: support@futuresoft.com

Visit the FutureSoft web site for more information at www.
futuresoft.com
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Installation

Before You Begin

This section details activities to complete before, during
and after installation. Read through all information in this
section and complete the following activities.

¥ Check system requirements

The minimum requirements for operating DCS 9 on
a personal computer are:

e Software

Windows 2000 Professional
Windows 2000 Server
Windows XP

Windows Server 2003
Windows Vista

Windows Server 2008

e Hardware

Pentium III processor

50MB hard drive space for a complete installation
CD-ROM drive

At least one of the following:

* For direct connections, one free serial port

* For phone line connections, a modem

* For network connectivity, a network inter-
face card

¥ Remove previous versions of DCS

To upgrade from version 7.0 (or eatlier) of DCS,
remove any prior version before installing DCS 9. If
you are not sure which version of DCS is installed,
select About DynaComm from the Help menu to
display product version information.

Files created after DCS 7.0 is installed, such as session
files and scripts, are not removed during the uninstall
process. These files can be stored elsewhere during the

installation procedure.
Backup the installation media

You are licensed to create up to three backup copies of
DCS 9 installation media. Create at least one backup

copy and use it for installation.
Register DCS 9
Registration for DCS 9 is online at:

http://www.futuresoft.com/forms/register.asp

Close applications

Before starting the installation program, quit any
running applications to ensure a smoother installation

process.
Locate the product serial number

After installation, license DCS with the Licenser
program using the serial number received from
FutureSoft.
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Working with the Setup Program

The Setup Program guides you through the installation of
DCS 9. Setup uses two basic functions: Starting and Exit-
ing.

Before starting the Setup Program, be sure that you have
reviewed all the material in the Single User section in this

chapter. That section provides background information for
the responses required for the Setup Program.

Working with the Setup Program includes:
Step 1: Start the Setup program.

More than one method can be used to start the
Setup Program.

Step 2: Respond to Setup screens to install appropriate
components.

The Setup Program presents a series of screens that require a
response for each. Details for each screen are provided in the
following chapters.
Starting Setup
The Setup Program is started through the:

Y FutureSoft Connectivity Products menu

¥ Windows Run dialog

¥ Add/Remove Programs selection in Windows Control
Panel.

CD Autorun

If CD Autorun is enabled on the install machine, the
FutureSoft Connectivity Products menu appears when you
insert the installation CD-ROM in the appropriate drive.

In addition to installing the software, the FutureSoft Con-
nectivity Products menu offers other choices for viewing
documentation or other items on the CD-ROM.

Windows Run Dialog

If CD Autorun is disabled, the Setup program can be
started from the Windows Run dialog.

¥ To start the Setup Program from the Windows Run
dialog:

1 Place the installation CD-ROM in the appropri-
ate drive.

2 On the Windows task bar, click Start and then
select Run.

3 In the Run dialog, enter the CD-ROM drive
name followed with “setup.exe”.

4 Click OK.

Windows Control Panel

The Setup Program can also be started from the Add/Re-
move Programs selection in the Control Panel window.

¥ To start the Setup Program from the Windows Control

Panel:
1 On the Windows task bar, click Start.
2 Highlight Settings and select Control Panel.

Double-click Add/Remove Programs.

B W

In the Add/Remove Programs Properties dialog,
click Install.

5  Place the installation CD-ROM in the appropri-
ate drive.

6 In the Run Installation Program dialog, click
Next.
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Welcome Dialog

The InstallShield Wizard dialog appears to indicate the sta-
tus of the installation program load. When Setup initializa-
tion is complete the Welcome screen appears. Setup is ready
to begin installation of DCS 9.

Exiting Setup

During the installation process, if you click Cancel on any
screen, the Exit Setup dialog appears.

¥ To respond to this screen, click cither:

*  Yes to stop the installation and exit the Setup

Program.

* No to return to the previous screen and continue
with Setup.

Single-User Installation

After completing pre-installation activities, follow the steps
below to set up an individual copy of DCS 9. These steps
use the standard install method for installing from a CD-
ROM.

Some steps may ask to enter information or to make a
choice. Read the descriptions carefully before completing
the step. Most steps do allow you to return to the previous
screen to make changes, if necessary. However, copying of
DCS 9 files begins when you click Next on the Select Us-
age screen. To make corrections at this point, you will need
to remove DCS 9 and reinstall.

Step 1: Start the Setup Program

Start the installation program using one of the techniques
discussed in Chapter 2 Setup Program.

Step 2: Respond to installation dialogs
Installation Dialog 1: Welcome

The Welcome message indicates that the Setup program
is now ready to begin installation of DCS 9 and reminds
you to quit any running applications. It also includes the

copyright warning.
To respond to this dialog
¥ Choose one of the following:
¢ Next to continue with the installation.

e Cancel to exit Setup.
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Installation Dialog 2: License Agreement

Installation and use of DCS 9 is governed by the terms of
the online license agreement. Make sure you read and agree
to the terms of the agreement before installing DCS 9.

If you have any questions about the terms of the online
license agreement, please contact your FutureSoft account
manager or send e-mail to info@futuresoft.com.

To respond to this dialog

1 Choose to accept/not accept the license agreement

terms.

2 Choose one of the following:
e Back to return to the Welcome dialog.
e Next to continue with the installation.

e Cancel to exit Setup.

Installation Dialog 3: Customer Information

The Customer Information identifies you to DCS 9. You
must complete both entries to continue the installation.

To respond to this dialog
1 Enter the following:
*  Your full name in User Name.
*  Your company name in Organization.
2 Choose one of the following:

e Back to return to the Software License Agree-
ment dialog.

e Next to continue with the installation, or

e Cancel to exit Setup.

Installation Dialog 4: Setup Type

Four options are presented for installing components and

sub-components of DCS 9:
¥ Complete
¥ Custom

See the first page of this chapter for a description of each

option.
To respond to this dialog
1 Select one setup option.
2 Choose one of the following:

e Back to return to the Choose Destination Loca-
tion dialog.

e Next to continue with the installation.

* Cancel to exit Setup.
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Optional Installation Dialog: Custom Type

When the Custom setup type is chosen, the next dialog
shown is Custom Setup.

All components of the base product and all Client Options
are shown. Each component displays the local hard drive
icon which means that it will be installed on the local hard
drive. To change how, or if, the component is installed, click
on the down arrow on the hard drive icon and select from

one of the available options:

¥ This feature will be installed on local hard drive

makes no visible changes.

¥ This feature, and all sub features, will be installed on
local hard drive makes no visible changes.

¥ This feature will be installed when required places a
yellow numeral one (1) in place of the disk drive icon.

¥ This feature will not be available places a red “X” on
the drive icon.

Selecting a component name displays space requirements for

the selected component in the Feature Description group.
To see space requirements for all selected components, click
Space in the dialog button bar to display the Disk Space
Requirements dialog. This dialog lists the available space
on the selected drive and the space requirements for the se-
lected DCS components. Highlighted volumes indicate that
space requirements for DCS are greater than the available
space. Click OK to return to the Custom Setup dialog.

On the Custom Setup dialog, Install to displays the loca-
tion where DCS files will be installed. The default location
is the C:\Program Files\FutureSoft\DCSeries folder. Use
Change... to modify this location, if needed.

To respond to this dialog
1 Change components and sub-components as needed.
2 Choose one of the following
*  Back to return to the Select Setup Type dialog.
e Next to continue with the installation.

* Cancel to exit Setup.
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Installation Dialog 5: Ready to Install the Program

The Ready to Install the Program dialog allows you to
return to previous screens to make any last minute changes.

To respond to this dialog
¥ Choose one of the following
*  Back to return to the Select Setup Type dialog.
* Install to continue with the installation.

e Cancel to exit Setup.

Installation Dialog : InstallShield Wizard Completed

The InstallShield Wizard Completed dialog is the last dialog
displayed in the installation of DCS 9. Two options are
provided:

To respond to this dialog

¥ Click Finish to complete the installation.

Installation of DCS 9 is complete.

Licensing DCS 9 and Client Options

If you installed an evaluation version of DCS 9 or would
like to activate a Client Option, the Licenser utility applies
the serial number that you received from FutureSoft. The
Licenser utility is started from the DynaComm Connectivity
Series 9 program group.

To apply a valid serial number

1 On the Windows task bar, click Start and highlight
Programs.

2 Highlight DynaComm Connectivity Series 9 and
click Licenser.

The FutureSoft Licenser dialog appears.

3 Enter the serial number in the provided box and click
License.

The DynaComm Connectivity Series dialog appears.
4 1In the User Information group, do the following:
a In User name, enter a complete user name.

b In Organization, enter a complete organization or

group name.
5 Click OK.
A confirmation dialog appears.
6 Click OK.
A question dialog appears.
7 Do one of the following:
*  Click No to end the licensing function.
e Click Yes to repeat steps 3 through 6.

Optionally, the Licenser utility can be run from a command
line or in a batch file. The command takes the form of:

licenser /L #######H##HHHHHHEHEHEHEEE

where “#” represents the base product or Client Option

serial number.

Note: Licensing on Windows Vista systems requires Ad-

ministrator access rights.
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Installation Troubleshooting

If you encounter an error while installing DCS 9, one of

the following common installation problems may have oc-

curred:

General file transfer error

The Setup program was unable to copy the files to
your destination directory. Make sure you have per-
mission to write to or modify the specified destination

directory.
Error reading disk drive

Make sure the CD drive is in proper working order.
Try reading another CD in the same drive.

Make sure you have inserted the installation CD cor-
rectly in the disk drive — the label should be face up.

If the drive is functioning and the media is properly
inserted, the disk may be defective. If you are install-
ing from a backup copy, install from the original
media instead. If you are installing from the original
media, please contact your FutureSoft Account Man-

ager for a replacement.

Installation has detected a previous version of the
DynaComm Connectivity Series

DCS 9 cannot be installed over a previous version
of DCS. You must remove the previous version first,

then install DCS 9.
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Chapter 3
Tutorial

This chapter presents the five basic functions of DCS 9 in
a tutorial. Begin with the first topic, Getting Started, and
work through each topic in the order presented. Each topic
builds on the information presented in the previous topic(s)
and assumes you have completed all prior topic(s).

The topics are arranged to give you a progressive overview
of the most commonly used functions. The topics covered
in this tutorial are:

¥ Lesson 1: Getting Started

Reviews methods for starting the DCS 9 application.
¥ Lesson 2: DCS 9 Files & Folders

Describes files and folder structure used by DCS 9.

Lesson 3: DCS 9 Window

Describes the DCS 9 application window compo-
nents.

Lesson 4: Working with a Terminal Session

Reviews procedures for creating, saving and opening
terminal sessions.

Lesson 5: Transferring Files

Discusses the process and procedures for moving files
to and from a host to a local terminal.

Lesson 6: Printing

Reviews all print commands and options.
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Lesson 1: Getting Started
This first lesson:
¥ Describes the DCS 9 program group.
¥ Presents methods for starting DCS 9.

¥ Lists steps to open DCS files.

DynaComm Connectivity Series 9 Program
Group

The DynaComm Connectivity Series 9 program group is
created during the installation process. It is added to the

Programs section of the Windows Start menu.

@- DwnaCommm Connectivity Series 9 —
ﬁ Futuresaft on the Weh

@ Licenser

ﬁ Cnline Registrakion

DCS 9 application

Link to home page on FutureSoft web site
Authorized DCS 9 Licenser utility

Link to online registration page on FutureSoft web site

Figure 3.1

DynaComm Connectivity Series 9 Program Group.

Starting DCS 9
¥ To start DCS 9 from an icon

*  On the Windows desktop, double-click the icon
associated with DCS 9.

¥ To start DCS 9 from the Start menu

1 On the Windows task bar, click Start and high-
light Programs.

2 On the Programs submenu, highlight
DynaComm Connectivity Series 9 and click
DynaComm Connectivity Series 9.

¥ To start DCS 9 from a browser window
1 Start the Internet browser.

2 In Address, enter the full path of the DCS 9 ap-
plication file location press Enter.

¥ To start DCS 9 from a command line

1 On the Windows task bar, click Start and select
Run.

2 In the Run dialog, enter dcseries and click OK.
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Lesson 2: DCS 9 Files and Folders

This second lesson:

¥ Presents all installed DCS 9 folders and describes the

Folders

When DCS 9 is installed, several folders are created to hold

files stored in each.

in each. Note that VBClient has several sub folders.

¥ Lists each file type and the file name extension.

files used by the program. Figure 3.2 lists all folders created
in a DCS 9 installation with a description of the files stored

e p—

conn
B2 —— display
= ) —— documentation
=y dnload
=y —— emul
=y fonts
iy ft
=y —— maps
=y memos
=y scripts
=[5y session
=y trace
=y upload
Iy vbclient
B ~_ samples
D asp
@ vb

connector (*.flx) files

display (*.flx) files

Administrator, User and Script guides (*.pdf)
downloaded files (default target folder)
emulation (*.flx) files

font files used by DCS

file transfer (*.flx) files

attribute (*.acm) and keyboard (*.kbd) files
memo (*.dcm) files (default target folder)
script (*.dep & *.dct) files (default target folder)
session (*.ses) files (default target folder)
trace (*.trc) files (default target folder)

files to upload (default target folder)

Visual Basic Interface files (default target folder)

sample Active Server Page (*.asp) files

sample Visual Basic (*.vbp, *.vbw & *.frm) files

DynaComm Connectivity Series 9 folders and files.
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The default location for install folders is:

c:\Program Files\FutureSoft\DCSeries

Certain folders are created in a second location:

= I2) Documents and Settings

=l |2 username

(= I2) Personall

All folders, except VBClient, can be moved and redirected
through the File Locations tab of the Options dialog. How-
ever, we recommend that “default” folders remain in their

original install location to ensure function integrity.

Dptions <]
General  File Locations I

Directory Types: User Directany:

IC \Program FileshFuturesofthDCS eries\EMUL J
Cannectors

File Transfers

Displays User Default Module:

Downloads

Do [prsiees [

Traces Reset &l
oK I Cancel | Help |

Figure 3.3
File Locations tab of Options
dialog.
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Files and File Types

When DCS 9 is installed, eight (8) file types are placed
in the install folders. Each file type has a specific function
within DCS 9.

¥ Document files are opened and edited in DCS 9.
These files can be associated with an icon placed on
the desktop. Double-clicking on the file name or the
associated icon starts DCS 9 and opens the file.

FutureSoft File Type File Extension
Memo document *.dem

Script document *.dcp

Session document *.ses

¥ When a script document (.dcp) is compiled, a com-
piled script file (.dct) is created. These files are run or
executed inside DCS 9 and can be associated with an
icon. Double-clicking the file name or associated icon
starts DCS 9 and runs the script.

FutureSoft File Type File Extension

Script file (compiled script) ~ *.det

¥ Program support files have extensions of .acm, .kbm

and .trc. These files are loaded by DCS 9 when a ses-
sion file is opened. These files are not opened directly
in DCS 9 or in any other application.

FutureSoft File Type File Extension
Attribute Map file *.acm
Keyboard Map file * kbm

Trace Facility file *.tre

Session properties for emulations, connectors and file
transfer protocols are stored in application files with
an extension of .flx. These files are used by DCS 9 and

are not opened directly.

FutureSoft File Type File Extension
Emulation object file * flx
Connector object file *flx

File Transfer object file * flx
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Opening Files

A4

To open a session file (*.ses), script document (*.dcp)
or memo document (*.mem) from the desktop

¢ Double-click an icon associated with the cor-
responding file or document.

To open a session file, script document or memo

document from a command line

1 On the Windows task bar, click Start and select
Run.

2 In the Run dialog, enter “filename.ext “and click
OK.

Where:

filename is a fully qualified path and name of
the session file, script document or memo
document to open when DCS 9 starts.

.ext is the corresponding file extension.

Note: The opening and closing quotation marks
must be included.

To open a session file in DCS 9

1 On the File menu, highlight Open and click Ses-
sion.

2 In the Open dialog, select a session file and click
Open.

To open a script document in DCS 9

1 On the File menu, highlight Open and click
Script.

2 In the Open dialog, select a script document and
click Open.

To open a memo document in DCS 9

1 On the File menu, highlight Open and click
Memo.

2 In the Open dialog, select a memo document and
click Open.

Starting a Script

¥ To start a compiled script (*.dct) from the desktop

*  Double-click an icon associated with a compiled
script file.

¥ To start a compiled script (*.dct) file from a command

line

1 On the Windows task bar, click Start and select
Run.

2 In the Run dialog, enter “script.dct “and click OK.
Where:

script is a fully qualified path and name of the
script file to execute when DCS 9 starts.

Note: The opening and closing quotation marks
must be included.

Tip: Use Browse to select the file to open.

¥ To start a compiled script (*.dct) file in DCS 9

1 On the Script menu, click Run.

2 In the Select a script file to execute dialog, select
a compiled script file and click Open.
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Lesson 3: DCS 9 Window Window Elements

This third lesson The DCS 9 application window presents standard interface

tools that you may have used with other Windows applica-

Reviews major elements of the DCS 9 window. tions. Figure 3.4 identifies common elements of the DCS 9

¥ Describes all toolbar buttons application window.
Menu bar Toolbar Window Controls
Displays names of menus Click to access Click to modify window
that list commands frequently used dimensions.
grouped by function. commands.

File Scrpt Wiew Tools Help

Dl=(a] & (e (2] E===] =[e]%|

Ready Jo [ [ R

Messages Status Indicators Size Grip

Displays messages Displays current Click and drag to resize

about DCS 9 or system conditions the horizontal and vertical

the session. or modes. dimensions of the window.
Figure 3.4

DynaComm Connectivity Series 9 Window.
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Toolbar

The standard DCS 9 toolbar provides 13 quick-access but-
tons for frequently used functions. Each button has a menu
equivalent.

Tool Tooltip Description

New Starts New Session wizard or opens last document type
opened

Open Displays File Open dialog

Save Saves active session properties

Cut Places copy of highlighted text on clipboard and removes

text from the display

Copy Places copy of highlighted text on clipboard
Paste Places copy of clipboard contents in display at cursor
position
Session Properties Displays Session Properties dialog for the active session
Connect/Disconnect Toggles active session connection status with host speci-

fied in session properties

Send File Displays Send File dialog to start transfer of file from

local system to remote host (upload)

Receive File Displays Receive File dialog to start transfer of file from

a remote host to local system (download)

Print Prints contents of active window
@ About Displays About DynaComm dialog
What's This Activates What's This? help feature

Table 3.1

Toolbar quick-access buttons.
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Lesson 4: Working with a Session
This fourth lesson

¥ Odudlines steps to create a session.
Reviews changing session properties.

Saves a session and opens a saved session.

Works with multiple session windows.

Creating a Terminal Session

A terminal session includes, at a minimum:
¥ An Emulator
¥ A Connector

A file transfer protocol can be selected but is not required.

By default the New Session Wizard is enabled when DCS
9 is installed. The New Session Wizard guides you through
the process of selecting the minimum requirements for
creating a session.

General | File Locations |

OLE
W Enable OLE menu

% Show spiash screer

¥ Prompt disconnect & save when closing
¥ Enable OLE toolbar
¥ Save application size

I Enable OLE status har

Width: m Height: ,ﬂ

¥ Use 'New Session' Wizard

[? Show background bitmap

= |

Cancel Help

Figure 3.5
General tab of Options dialog.

The New Session Wizard is disabled by clearing the Use
‘New Session’ Wizard option on the General tab of the Op-
tions dialog (Tools > Options).

If the New Session Wizard is disabled or no selections are
made, DCS 9 automatically includes the following session
properties:

¥ ANSI-BBS emulation
¥ Telnet connector
¥ ZModem file transfer protocol

Session properties are changed through the Session Proper-
ties dialog.

Note: Default session properties may be changed by
your system administrator.

The following steps to create a terminal session use the New
Session Wizard. If the wizard is disabled, continue to step 5
after completing step 1.
Step 1: Access the New Session Command
¥ To create a new session, do one of the following
e Click the New Session toolbar button.

*  On the File menu, highlight New and click Ses-
sion.

The New Session wizard starts and displays the New Ses-
sion Wizard - Emulator Type dialog appears (see Figure 3.6).
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Step 2: Select an Emulation

The New Session Wizard - Emulator Type dialog lists all
installed emulations.

New Session Yizard - Emulator Type

The New Session Wizard will help you quickly selectthe
correct modules for your connection.

VT 420
TN6530

T&T 4425
ANsLe

Flease select the type of emulation to use

Wyse 50(60
ADDS VP/6

TNS250

¥ Use new session wizard

Step 3: Select a Connector

The New Session Wizard - Connector Type dialog lists all
installed connectors.

New Session Wizard - Connector Type

Flease select the type of connection to use:

Direct Serial

< B I et > I Cancel Help |

<Back I et > I Cancel Help

Figure 3.6
New Session Wizard -
Emulator Type dialog.

To respond to this dialog
e Select an emulation and click Next.

The New Session Wizard - Connector Type dialog appears.

Figure 3.7
New Session Wizard -
Connector Type dialog.

To respond to this dialog
e Select a connector and click Next.

The New Session Wizard - File Transfer Type dialog ap-

pears.
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Step 4: Select a File Transfer Protocol

The New Session Wizard - File Transfer Type dialog lists all
installed file transfer protocols except for FutureSoft FTD.

New Session Wizard - File Transfer Type [x]

Flease selectthe type offile transferto use:

Cancel Help |

I Finish I

< Back

Figure 3.8
New Session Wizard -
File Transfer Type dialog.

This protocol is provided as a standalone FTP utility which
can be started from the DCS 9 window with the Tools >
FTP command or on its own, as described at the end of

Lesson 5.
To select a file transfer protocol
*  Select a file transfer protocol and click Finish.

The Session Properties dialog appears.

Step 5: Make Session Property Changes

The Session Properties dialog appears each time a new ses-
sion is created. The Connectors tab is displayed.

Session Properties

Connectors | Emulations | File Transters | Displays | General | Mause | Trace |

#l=[=]=]a

Direct Serial|__LAT32 Modem | SNA Server| Telnet

General
Device Control Parameters:

Eort E
Baudrete: 9500 -
8 g

& Hardware (RTS/CTS)
(P None | € Software (XON/XOFF)
[ - € Nons

I Enable Parity Che cking
I¥ Drop DTR ta Disconnect

Databits Hancishaking

Stop bits,

(3 Cancel Help

Figure 3.9
Connectors tab of the Ses-
sion Properties dialog.

To complete session configuration, you must specify a:
¥ Network host, if Telnet connection is used.

¥ Serial communication port, if direct serial connection

is used.
¥ Phone number, if modem connection is used.
To respond to this dialog

1 Supply the required corresponding connection infor-

mation.
2 Click OK.

The connection is made and a session window opens.
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Step 6: Saving the Session

The configured session properties are valid only for the cur-
rent instance of the session. To retain the configured session

properties, you must save the session.
To save a session with the default session file name
1K On the File menu, click Save or Save As.

The default session file name appears in File Name in
the Save As dialog.

2 Click Save.
To save a session with a custom session file name
1 On the File menu, click Save As.

The default session file name appears in File Name in
the Save As dialog.

2 In File Name, enter a new file name and click Save.

Step 7: Opening a Saved Session
Saved session files are stored in the Session folder.
To open a saved session

1 On the toolbar, click Open.

2 Select a session file and click Open.

Working with Multiple Windows
DCS 9 is designed with a Windows Multiple Document

Interface (MDI). Multiple session files, scripts, or memo

documents can be open in a single instance of DCS 9.

Use the Windows menu to view a list of all open windows.
A check mark appears next to the active window. Click a
window in the list to make it the active window. Multiple
windows can be arranged to fit the application workspace.

To arrange multiple windows
1 On the application menu bar, select Windows.

2 On the Window menu, select the desired windows
arrangement.

* Cascade arranges the windows in an overlapping
stack of equal sized windows such that the title
bar of each window is visible.

 Tile Horizontally arranges the windows in equal
horizontal widths that fill the application window.

* Tile Vertically arranges the windows in equal
vertical widths that fill the application window.
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Lesson 5: Transferring Files
This fifth lesson :
¥ Reviews selecting a file transfer protocol.
¥ Outlines steps to send files (upload) to a host.
¥ Odudlines steps to receive files (download) from a host.

¥ Describes the FutureSoft FTP utility.

File Transfer Protocols

When creating a new session, only installed file transfer
protocols appear in the Session Properties dialog. The file
transfer protocol can be changed at any time. However,
changing protocols automatically disconnects and then
re-connects the session to the host. Therefore, to ensure data
transfer integrity, do not change the protocol during a file
transfer. Stop the current transfer first, change the protocol,
and then re initiate the transfer.

To select or change a file transfer protocol
1 On the Session menu, select Properties.

2 In the Session Properties dialog, click the File Trans-
fers tab.

3 Select a file transfer protocol button.

4 Click OK to close the Session Properties dialog.

Sending Files (Upload)

After a connection to a host has been established, the Send
File and Receive File commands are enabled. DCS 9 can
transfer files to any host that supports the configured trans-
fer protocol. To transfer a file to a host, the host system or
application must be readied to receive a file.

Note: Within DCS 9, the configuration requirements
for sending a file to a host will vary by host, host
application, and the file transfer protocol. The de-
fault file transfer protocol settings can be changed
to suit your particular host or host application.

To send a file to a host

1 Configure the host or host application to receive a

file.
On the toolbar, click Send File.
3 In the Send File dialog, specify the file(s) to transfer.

If changes to the file transfer protocol configuration
are needed for this transfer only, click Setup and
make the changes in the Session Properties dialog.

4 Click OK to start the transfer.

The File Transfer Status dialog appears to show the
progress of the file transfer.
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Receiving Files (Download)

After a connection to a host has been established, the
Receive File command is enabled. To receive a file, the host
system or application must be readied to send a file. Check
with your system administrator or consult the host applica-
tion documentation if you need assistance configuring the

host to send a file.

Note: Within DCS 9, the configuration requirements
for sending a file to a host will vary by host, host
application, and the file transfer protocol. The de-
fault file transfer protocol settings can be changed

to suit your particular host or host application.
To receive a file from a host

1 Configure the host or host application to send a

file(s).

Note: By default, when a host sends a Receive
command to start a file transfer, ZModem
autostarts. This option may be turned off. See
the Online Reference for more information.

If ZModem autostarts the transfer, the file
name is sent in the first packet.

2 On the toolbar, click Receive File.

3 In the Receive File dialog, specify the file(s) to trans-

fer.

If changes to the file transfer protocol configuration
are needed for this transfer only, click Setup and
make the changes in the Session Properties dialog.

4 Click OK to start the transfer.

The File Transfer Status dialog appears to show the
progress of the file transfer.

FSFTP utility

The FSFTP utility supports file transfers to and from a host
using the FTP protocol over a TCP/IP connection. You may
request this utility from FutureSoft Support services.

ESFTP installs in the installation directory of DCS 9. The
DynaComm Connectivity Series 9 program group provides
a shortcut to start FSFTP outside of DCS 9. If you have
started DCS 9, access FSFTP with the Tools > FTP com-

mand.

An Online Reference (Help system) for FSFTP is provided
with the udility.
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Lesson 6: Printing

DCS 9 offers a range of local printing options, including:
¥ Printing the current screen

Printing a selected area

¥ Printing the entire contents of a session

¥ Allowing the host system to send raw data directly to
your local printer

¥ Printing using a specific font, and adding header and
footer information to each page

Before printing, a printer must be installed and configured.
The printer can be a local or network resource.

Printer configuration

Although you must install local printer drivers using the
Windows Add/Remove Hardware wizard, you have the
option of configuring an installed printer without closing

DCS 9.
¥ To configure a printer
1 On the File menu, select Print Setup.
2 In the Print Setup dialog, select a printer.

3 Click Properties and configure the printer as
needed.

Note: Changes to printer properties are tempo-
rary and affect only the current print job.
They are not saved with the session, script,
or memo file and have no effect on print

jobs for other windows or applications.
4 Do one of the following:
e Click OK to accept the print setup
* Click Cancel to discard changes.

Note: Local printing options do not affect out-
put printed to a host or remote system.

Print Setup Options (Session Only)

For individual print jobs, a specific printer, font, and header
and footer elements can be specified using the Print Setup
dialog. The File > Print Setup command displays this
dialog. Print setup for memo and scripts use the Windows
Print Setup dialog.

Print Setup

I

— Printer: oK
& Defeult:  HP LaserJet 44P B00dpi I—I
 Spagific o]
EBroperties
—Font:
 Screen Help
" Bpecific
— Option
Baw Passthrough Mocle Auto j

I~ Keep Print Channel Open Between Host Print Jobs

—Page

Header: [8L25 * Footer I&C&P |

Figure 3.10
Print Setup dialog.

¥ To configure an individual print job

1 On the File menu, select Print Setup.

2 In the Print Setup dialog, select a printer.
3 Select a font.
4

Use the default settings for Raw Passthrough
Mode. If you wish to use a different setting, see
the Online Reference for more information.

5 Select the right arrow buttons next to the Header
and Footer fields to add information at the top
and bottom, respectively, of each printed page.

6 Click OK to accept the print job configuration, or
click Cancel to discard any changes.

Note: Local printing options do not affect print
output to a host or remote system.
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Print Preview

Before sending a job to a printer, print results can be viewed

online. Options include viewing pages either side-by-side or

one at a time, in two levels of magnification.

¥ To preview a print job

1

Display the item to be printed in the active win-
dow by selecting the corresponding window title
from the Window menu.

Window title is the name of the session, script, or
memo to be printed.

On the File menu, select Print Preview.

The Print Viewer window replaces the session,
script, or memo window. By default the Print
Viewer displays one page at a time for multiple

page previews.

Select the functions on the Print Viewer toolbar
as needed.

Tip: Each window provides its own print preview.
Therefore, two or more print previews can
be compared side-by-side by selecting a til-
ing option from the Window menu.

To...

Print...

Iext Page

Frew Page

Twio Page

Zoom In

Zoom Cut

[
7
o)
—
2
)
o)
c
=
o
=

Cloge

Table 3.2

Sends the job to the printer and closes
the Print Viewer window.

Displays the succeeding page in a mul-
tiple page print preview.

Displays the prior page in a multiple
page print preview.

Creates a simple print view display of
two consecutive pages.

Enlarges the page size in the print

Viewer window.

Reduces the page size in the Print

Viewer window.

Closes the Print Viewer.

Print Viewer functions.
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Printing a Session Window, Script or Memo
Document

The Print dialog is used to make changes to a print job.

Print
Printer.  System Printer (HP LaserJet 4MP E00dpi)
Frint Opticn Cancel |
& Current Screen
1 Bl i 4|§etup. _
Al
™ Printta File HEI_Ip
Figure 3.11

Print dialog.

¥ To print from an open session window

1

Display the item to print in the active window by
selecting the corresponding window title from the
Window menu.

Window title is the name of the session, script, or
memo to be printed.

On the File menu, select Print.
The Print dialog appears.

Note: Open sessions that have not been con-
figured or have not attempted a connec-
tion appear as an empty window. These
windows cannot be printed.

3 Select a print option.

4 Click OK.

Printing to a File

Print output can redirected to a file. The contents of the

file is raw print data that can be viewed with any text editor

(such as NotePad). However, to print the file in a format

other than raw data, it must be sent to a printer that uses a

Printer Control Language (PCL) print driver.

¥ To send the file to a printer for output

1

Enter the following at a DOS command prompt

copy filename.ext LPTx /B

where:

filename is the fully qualified path and name of
the file (such as c:\sales\june99.prn)

.ext is the file extension (usually .prn)
x is the LPT port number (such as LPT1)

/B indicates that the file is a binary file

2 DPress Enter.
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Chapter 4
Removing DCS 9

Removing All Components Step 2: Respond to Setup Dialogs

The uninstall utility removes only those items installed by

Setup Dialog 1: Welcome

the Setup program. It does not remove session files, scripts,

memo documents, custom keyboard maps, or any other file ~ The Welcome dialog appears when the Setup Program has
not installed by Setup. Also, it does not remove an installed completed loading.

file that has been renamed. Removing the base DCS 9 To respond to this dialog

program also removes all Client Options.
¢ (lick Next.

Step 1: Start the Setup Program
Setup Dialog 2: Program Maintenance

Start the Setup Program using one of the techniques dis-

cussed in Chapter 2 Setup Program. The Program Maintenance dialog offers three options. The

Remove option removes all program components, including

Client Options, of DCS 9.
To respond to this dialog
¢ Select Remove.

¢ Click Next to start the removal.

Setup Dialog 3: Remove The Program

The Remove the Program dialog appears to confirm the

removal.

¢ Click Remove to start the removal.

Setup Dialog 4: InstallShield Wizard Completed

The InstallShield Wizard Completed dialog appears when
the removal is complete.

To respond to this dialog

e Click Finish to close the Setup Program.
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Removing Selected Components

The Setup program can remove selected components and/or
sub-components of DCS 9. When the Custom Setup dialog
appears, all installed components are listed.

Step 1: Start the Setup Program

Start the Setup Program using one of the techniques dis-
cussed in Chapter 2 Setup Program.

Step 2: Respond to Setup Dialogs

Setup Dialog 1: Welcome

The Welcome dialog appears when the Setup Program has
completed loading.

To respond to this dialog

¢ (lick Next.

Setup Dialog 2: Program Maintenance

The Modify option allows for removal of selected program

components.
To respond to this dialog
¢ Select Modify.

¢ Click Next to start the removal.

Setup Dialog 3: Custom Setup
¥ To remove a component,
1 Select the item.

2 On the pop-up menu, select “This feature will not
be available”.

3 Choose one of the following

e Back to return to the Select Setup Type
dialog.

¢ Next to continue with the removal.

* Cancel to exit Setup.

Setup Dialog 4: Ready to Modify the Program

The Ready to Modify the Program dialog appears to con-
firm the removal.

e (lick Install to start the removal.

Setup Complete

The InstallShield Wizard Completed dialog appears when
the removal is complete.

To respond to this dialog

* Click Finish to close the Setup Program.
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documentation library 10
documents

memo 25

script 25

session 25
download files 23, 28, 34

E

e-mail 12, 16
eBooks 10-12
editor 6
EHLLAPI 6
EM3270 support 8
emulations
add-on 6
ANSI-BBS 29
base product 6
default 29
HP 700/92 8
installed 30
Tandem 6530 8
TN3270 9
TN5250 9
errors, installation 19
euro symbol 6
evaluation version 18
extensions, file types 25

F

files 23
Attribute Map 25
connector 25
copying 15
display 23
emulation 25
file transfer 23, 25
font 23
Keyboard Map 25
opening 26
Readme 10, 11
receiving (download) 34
sending (upload) 23, 33
session 23
Trace Facility 25

transferring 23, 28, 33-34

file transfer 19

file transfer protocols
default 29
installed 31, 33-34

file transfer protocols, supported
AT&T 4425 7
base product 6
HP 700/94 8
Tandem 6530 6, 8
TN3270 6,9
TN5250 9

file types 25

file version 10

folders 23

font
files 23
used in printing 35

FTP protocol 7,8

H

help, finding & using 11

HLLAPI Auto-Launch Configurator utility 10
HLLAPI Interface 9

host application 33, 34

hotspot support 8, 9

HP 700/94 Client Option 6, 8
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Multiple Document Interface (MDI), Windows 32

N

New command 28

New Session Wizard 29-32
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Emulator Type dialog 30
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NotePad, Windows 37

0]

OLE 6
Online Reference(s) 10-11
Open command 28
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General tab 29
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Paste command 28
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printing 28, 35-37

to afile 37
Print command 28
Print dialog 37
Print Setup dialog 35
Print Viewer 36
program group 18
program group, DCS 9 22
properties, session 33-34
protocols, file transfer 7, 8, 29

R

Raw Passthrough Mode 35
Readme file 10, 11
Receive File command 28
registration 22

Release Notes 10, 11
requirements, system 13

S

Save command 28
script(s)
compiling 25
documents 25, 26
files 25, 26
starting 26
scripting language 6, 10
Select Components dialog 40
Select Setup Type dialog 16
Send File command 28
serial number 13, 18
session
connection status 28
creating 29-32
files 23
open 32, 37
printing 35
properties 28, 29, 31, 33-34
saving 32
Session Properties command 28
Session Properties dialog 31
Setup Complete dialog 40
Setup Program 14-16, 15, 39, 40
SNA Server (Microsoft) connector 6
Software License Agreement dialog 16
soft fonts 8
Standard Install 11
support, technical 12
system requirements 13

T

Tandem 6530 Client Option 6, 8
Technical Support 12
TeleVideo 925/950 emulation 6
Telnet connector 6, 7, 8, 29
TN3270 Client Option 6, 9
TN5250 Client Option 6, 9
toolbars 27, 28, 36

Trace Facility files 25
transferring files 28
troubleshooting 19

tutorial 21-44
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U X

upgrading 11, 13

upload files 23, 28, 33

User Information dialog 16-20

utilities Y
Licenser 18, 22

XModem protocol 7, 8

Y2K 6
y YModem protocol 7, 8
version 7
documentation 10
file 10 ZModem protocol 7, 8, 29, 34

product 12,13, 19

W

Web Install 11
web site 10, 22, ii
Welcome (Setup Maintenance) dialog 39, 40
Welcome dialog 15
What’s This command 28
window

active 32

DCS9 27

empty 37

multiple 32

Print Viewer 36
WinHLLAPI 6
wizard, New Session 29-32
Wyse 50/60 emulation 6
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